Jaguar F-Pace Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Just returned from a week of vacation to find my F Pace displaying an "SOS limited" warning in the message center.

The manual says this happens when there is a fault in the system or the back up batteries for the system are low. I was hoping a long drive today would recharge the back up batteries but the warning is still on.

Anyone else have this problem? Figured I'd ask before I made an appointment to bring it in.
 

·
Registered
Joined
·
5,074 Posts
We left ours sitting in the driveway for over *4* WEEKS while my wife was having surgery in Baltimore ! When we got back and started the F-pace up , we did not have any warnings ! We have done some short back and forth trips , but today we did a 60-mile each way trip to get some lunch up in Dover, DE , and our Baby is running just fine ! I hope yours is an easy fix , or just needs reset maybe !
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
UPDATE: dropped it off today, they said it was a "wiring issue." That and my leaky front diff means I'll be in a loaner Evoque until sometime next week. :crying:
 

·
Registered
Joined
·
66 Posts
UPDATE: dropped it off today, they said it was a "wiring issue." That and my leaky front diff means I'll be in a loaner Evoque until sometime next week.
Been there done that TWICE with the front differential. As far as the Evoque, I must say that it's a **** of a lot better than the Discovery. By no means is it in the same category as the F Pace but we enjoyed it enough to consider ordering a convertible one.
 

·
Registered
Joined
·
116 Posts
Discussion Starter #5
Update!

FIXED: Looks like it was just a failed part somewhere in the system, haven't heard of many others with this issue so I think it's fairly isolated. Per the invoice:

"Tech pulled fault codes and found fault for speaker wire open or shorted, and short to battery. Tech removed over head console and checked speaker short to ground, short to power, and shorts to each other. No shorts found. Checked grounds and power out put from TCU. All operating properly. Tech installed test TCU and code did not return. Created a Fred and installed new TCU. Programmed TCU and verified operation of TCU, and was operating properly."

They replaced "Module Telematic" with part # T2H18589.

Hopefully this is the end of it

In other news, they also:

- K434 MIL Lamp Illuminated P025C - 11 DTC JAGUAR RECALL
-K445 Coolant Level Check - COMPLETED JAGUAR RECALL
-K440 Front Lower Control Arm Cross Axis Gaiter Damage - COMPLETE JAGUAR RECALL

AND...

they confirmed fluid leaking from pinion seal and replaced my front differential.

Was out of service for about 3 days. Dealer service department was fine and all covered under warranty. A little frustrating as Jaguar was just name #10 in reliability, but I knew getting an early build had greater potential for issues and all these were minor to be honest. It was driving just fine when I brought it in and I hope it continues to perform well.
 

·
F Pace Expert
Joined
·
2,546 Posts
They really did get some bunk telematics units. Good catch on the differential.
 

·
Registered
Joined
·
5,074 Posts
Hey Roverdude , I bet you were singing
"I want my Baby Back Baby Back Baby Back , I want my Baby Back Baby Back Baby Back" !!!
And having it back must be a GREAT Feeling !!!
CONGRATS !!!
 
1 - 7 of 7 Posts
Top