Jaguar F-Pace Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Anyone else trying to play music from an iPhone connected via USB having issues?
I've had numerous issues with the ICTP. Just had Ver2.5 installed for second time last week (which took 5 days) and still numerous problems! The most frustrating is trying to play music from the iPhone.
Bluetooth seems to work ok, but can't browse playlists, albums etc, no artwork and sound is not as good. So I plug in the cable. It connects, wait a while, a long while and it starts to play. 30 seconds later it disconnects and switches back to radio. Wait for reconnect, go back and select iPhone USB. Then wait for ir it to respond, and wait, and wait. Finally, music and then 30 sec later disconnects again. Usually happens 3 or 4 times before it will finally play consistently.
The interface in general is dog slow. When I select playlist not all of them show up. Go back out, select Playlist again and get a different selection. Finally get in to one after a few attempts, select a song and it plays something different. Then it repeats a song, plays something different and then goes back to the last one. Even selecting the Next option gives a list showing repeated songs (not besseccarily adjacent to each other) - not that way on the iPhone.
This interface is a complete joke!
 

·
Registered
Joined
·
2,117 Posts
Anyone else trying to play music from an iPhone connected via USB having issues?
I've had numerous issues with the ICTP. Just had Ver2.5 installed for second time last week (which took 5 days) and still numerous problems! The most frustrating is trying to play music from the iPhone.
Bluetooth seems to work ok, but can't browse playlists, albums etc, no artwork and sound is not as good. So I plug in the cable. It connects, wait a while, a long while and it starts to play. 30 seconds later it disconnects and switches back to radio. Wait for reconnect, go back and select iPhone USB. Then wait for ir it to respond, and wait, and wait. Finally, music and then 30 sec later disconnects again. Usually happens 3 or 4 times before it will finally play consistently.
The interface in general is dog slow. When I select playlist not all of them show up. Go back out, select Playlist again and get a different selection. Finally get in to one after a few attempts, select a song and it plays something different. Then it repeats a song, plays something different and then goes back to the last one. Even selecting the Next option gives a list showing repeated songs (not besseccarily adjacent to each other) - not that way on the iPhone.
This interface is a complete joke!
I used to have this happen every time I got in the car before my entire ICTP unit was replaced (because they killed it while trying to update it). After update it is almost instantaneous that it connects and never disconnects anymore. One thing I can do is see whats up next, when I click on that nothing comes up, and a ton of my songs are missing when I go into see my playlists from the ICTP screen, but other than that it works great.

If it still isnt working after the updates I would inquire about getting a brand new ICTP unit.
 

·
Registered
Joined
·
6 Posts
I have been using my iPhone 6s+ (iOS 10.2 now 10.3.1) with my ICTP and it works perfectly. I get album art, can play, pause, advance and move back tracks. Not sure why everyone is so upset about no ACP, ICTP works well. Not saying ICTP doesn't have sopme quirks, it does, but playing music from iPhone using the USB port is not one I have encountered.
 

·
Registered
Joined
·
2,248 Posts
My connection through the USB cord has been rock solid since the 2.5 update was applied back in November. I did have some trouble initially, but I swapped out my cord and all the problems went away. So if you haven 't already, I would get a different USB cord and I would use an Apple one just to make sure the issues aren't the cord itself.

the other problem you could have is since it seems like your dealership had to apply 2.5 a couple times, they may not be skilled at doing those updates yet and aren't getting them completely done correctly. There are many modules that need to be updated and most people having issues after the 2.5 are the result of applications of the update that weren't finished completely or correctly it seems.
 

·
Registered
Joined
·
536 Posts
the other problem you could have is since it seems like your dealership had to apply 2.5 a couple times, they may not be skilled at doing those updates yet and aren't getting them completely done correctly. There are many modules that need to be updated and most people having issues after the 2.5 are the result of applications of the update that weren't finished completely or correctly it seems.
I would agree this is likely what is happening.
 

·
Registered
Joined
·
58 Posts
Discussion Starter #6
My connection through the USB cord has been rock solid since the 2.5 update was applied back in November. I did have some trouble initially, but I swapped out my cord and all the problems went away. So if you haven 't already, I would get a different USB cord and I would use an Apple one just to make sure the issues aren't the cord itself.

the other problem you could have is since it seems like your dealership had to apply 2.5 a couple times, they may not be skilled at doing those updates yet and aren't getting them completely done correctly. There are many modules that need to be updated and most people having issues after the 2.5 are the result of applications of the update that weren't finished completely or correctly it seems.
I did try a number of cables including a genuine Apple cable with no change.
Does anyone know if there has been any Topix/ updated related to the USB connection console in the center arm rest compartment? I also have a USB stick in there, which although it works is also very slow. Wondering if it has some issue with interface to main ICTP box in the trunk.
 

·
Registered
Joined
·
42 Posts
Apple iPhone 6s with USB connection.

For the first month or so, when I connected my iPhone and when I clicked Up Next, the songs from my iPhone were listed alphabetically on the ICTP screen. Now they are in completely random order. Anyone else run into this issue? I can't find a setting in ICTP or on my iPhone that will correct this issue. In order to see the tracks in alphabetical order, I have to use the Find function.
 
1 - 7 of 7 Posts
Top