Jaguar F-Pace Forum banner
41 - 49 of 49 Posts

·
Registered
Joined
·
1,559 Posts
Another issue.. all of my recent journeys on Jaguar Remote look like aircraft flights. They are point to point to destinations but not on streets! Ha!

Also,I tested CarPlay in my GMC vehicle and boom…. Connected to the iPhone wirelessly with CarPlay in a split second. Flawless…
 

·
Registered
2021 P 250S Charente Grey / Light Oyster
Joined
·
4 Posts
All, I’m happy to report that all of the cutting out issues appear to have been fixed by the dealer. It’s only been 4 days so fingers crossed. The dealer determined it to be the ICCM which I think is the main module that controls Pivi Pro. It was located under the passenger seat. They replaced it, and configured a new ECU. Since the radio ID is different, I contacted Sirius to give them the new ID and that was a simple process to activate satellite. We did have a problem connecting to wireless CarPlay after we picked it up. The dealer pushed out the newest software version again, and after 4 attempts, the download was successful. The system now responds quickly. I hope this post helps some of you with the self muting and cutting out issues. It took a year, but it’s fun to drive again.
 

·
Registered
Joined
·
1,559 Posts
I may bring this ICCM thing up to my dealer. We are on the latest download, and it still only connects to your phone about 50% of the time entering the vehicle. Will not recognize/ connect to CarPlay period. Carplay is not even on the menu to be selected and executed any more. Same phone works flawlessly in other vehicles. Was excited about Pivi initially, but that feeling quickly left a few months ago. Even my daughters Hyundai never misses a lick. How hard is this?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #49 ·
All, I’m happy to report that all of the cutting out issues appear to have been fixed by the dealer. It’s only been 4 days so fingers crossed. The dealer determined it to be the ICCM which I think is the main module that controls Pivi Pro. It was located under the passenger seat. They replaced it, and configured a new ECU. Since the radio ID is different, I contacted Sirius to give them the new ID and that was a simple process to activate satellite. We did have a problem connecting to wireless CarPlay after we picked it up. The dealer pushed out the newest software version again, and after 4 attempts, the download was successful. The system now responds quickly. I hope this post helps some of you with the self muting and cutting out issues. It took a year, but it’s fun to drive again.
This is good news. What evidence did you provide to the dealer. I’ve been going back and forth for weeks now.
 
41 - 49 of 49 Posts
Top