Jaguar F-Pace Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
337 Posts
Discussion Starter #1
I noticed these two loose connectors underneath the steering wheel (left of the brake pedal - US version car).

It seems like i might have a missing module in there which the connectors would plug into.

Wondering if you guys also have these loose connectors in your Fpaces. No need to remove anything to view that area. Simply go under the steering wheel with a flash light (and maybe a phone to get a photo) and you should be able to see those connectors.

I appreciate your help!
 

Attachments

·
Registered
Joined
·
1,540 Posts
These cars when assembled..(By hand, NOT ROBOTS)..They Have installed a wiring harness to accommodate every possible option that can be installed..If some of the options are not installed, the associated connector is left blank or unconnected to anything...I can not even guess what those connectors may have went to.
 
  • Like
Reactions: Kubota

·
Registered
Joined
·
2,152 Posts
These cars when assembled..(By hand, NOT ROBOTS)..They Have installed a wiring harness to accommodate every possible option that can be installed..If some of the options are not installed, the associated connector is left blank or unconnected to anything...I can not even guess what those connectors may have went to.
Or use standard connection blocks that have maybe a dozen connections, even if only one is used.
 

·
Registered
Joined
·
5,074 Posts
Hey JagFPace1 , for comparison reasons , it would be helpful if you posted in your signature , your Model , Stand Alone Options , Optional Packages , Gas or Diesel ! One of the connectors could be something as simple as someone saying that their connector is plugged in , and they end up having a Heated Windshield or HUD , and yours doesn't ! Still hard to know for sure , with all the freakin' wires in this vehicle , but might help !
Just a suggestion ! :)
 

·
Registered
Joined
·
116 Posts
These cars when assembled..(By hand, NOT ROBOTS)..They Have installed a wiring harness to accommodate every possible option that can be installed..If some of the options are not installed, the associated connector is left blank or unconnected to anything...I can not even guess what those connectors may have went to.
Very true. JLR has been doing this for years. In the early 2000s, Land Rover would build all their Disco II's with pre-wiring for heated seats, including the heating elements in the seats. If you didn't want to spend the $500 for the heated seat option, you could skip it, order the heated seat switches for $100 and change, and simply plug and play.

If we are able to figure what module does plug into those blanks, your car still may need a full dealer reprogramming to actually use it. Cars are so complicated these days that it's really more like a mini LAN vice electrical network so everything needs to talk to each other to work.
 
  • Like
Reactions: DPK

·
Registered
Joined
·
337 Posts
Discussion Starter #6
Hey JagFPace1 , for comparison reasons , it would be helpful if you posted in your signature , your Model , Stand Alone Options , Optional Packages , Gas or Diesel ! One of the connectors could be something as simple as someone saying that their connector is plugged in , and they end up having a Heated Windshield or HUD , and yours doesn't ! Still hard to know for sure , with all the freakin' wires in this vehicle , but might help !
Just a suggestion ! :)
That would be a Prestige Petrol
 

·
Registered
Joined
·
5,074 Posts
That would be a Prestige Petrol
Since we are looking at something Electrical , I was thinking a little more along the lines of :
ICT ? ICTP ? HUD ? Heated Windshield ? Luxury Package ? Vision Package ? Driver Assistance Package ? ACC ? Heated Steering Wheel ? Heated Seats ?
 

·
Registered
Joined
·
5,074 Posts
Hey JagFPace1 , I went and took a look at mine , and this is what I found ! The BIG greyish colored connector on mine is indeed hooked to a connection ! Also , as you can see , mine not only has the brownish telephone cord looking cable going into it , but also has a bunch of small wires going into it as well ! If you look at your photo , you will see how the black connector is mounted on a black piece of plastic , that has a secondary clip on it ! The cream colored connector on mine is clipped into that spot ! Just like yours , my small grey connector , is NOT hooked to anything !
I have ICTP , HUD , Luxury Package , Driver Assist Package , and the Comfort & Convenience Package ! I do not have the Heated Windshield !
 
1 - 8 of 8 Posts
Top