Jaguar F-Pace Forum banner

1 - 20 of 28 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Anyone else still having issues after the Oct Super Update. Although it seems to have fixed most of the many issues I had before, i still have a couple as below:
1. Slow to start. Sometimes I get a black screen after starting for up to a minute or so. Sometimes I get a flashing screen. Sometimes it loads but pressing on one of the panels gives me a 'not available' message - happens a lot with Navigation.
2. IPhone control is a nightmare. I usually try to use the cable - sometimes my phone takes forever to show up. I've tried the InControl music app before but that was painful so I usually control from the direct interface. It's very slow. I press playlist and wait ages. Sometimes it times out. Other times it does nothing for a few presses and then does a bunch of moves at once. If I scroll down the list a way and select a song it places something different. And recently it's started jumbling up the songs listing them all out of order and many duplicates (see pic). Most of the time it's unusable.
3. Trying to enter in the Nav is also painfully slow. Once it comes up, trying to enter an address takes forever. I press a letter/ number and it takes quite a few seconds for it to appear on the screen. To get through an address can take minutes.
4. Why did they change the AirCon icon to seats? I had a button below for the seats but now if I want to control the rear air-con there's no way to get to it.
I did hear there was a 2.5 update but supposed to be the same as Oct. Can anyone comment?
 

Attachments

·
Registered
Joined
·
258 Posts
Anyone else still having issues after the Oct Super Update. Although it seems to have fixed most of the many issues I had before, i still have a couple as below:
1. Slow to start. Sometimes I get a black screen after starting for up to a minute or so. Sometimes I get a flashing screen. Sometimes it loads but pressing on one of the panels gives me a 'not available' message - happens a lot with Navigation.
2. IPhone control is a nightmare. I usually try to use the cable - sometimes my phone takes forever to show up. I've tried the InControl music app before but that was painful so I usually control from the direct interface. It's very slow. I press playlist and wait ages. Sometimes it times out. Other times it does nothing for a few presses and then does a bunch of moves at once. If I scroll down the list a way and select a song it places something different. And recently it's started jumbling up the songs listing them all out of order and many duplicates (see pic). Most of the time it's unusable.
3. Trying to enter in the Nav is also painfully slow. Once it comes up, trying to enter an address takes forever. I press a letter/ number and it takes quite a few seconds for it to appear on the screen. To get through an address can take minutes.
4. Why did they change the AirCon icon to seats? I had a button below for the seats but now if I want to control the rear air-con there's no way to get to it.
I did hear there was a 2.5 update but supposed to be the same as Oct. Can anyone comment?
What model FP do you have. And what options do you have. Depending on the model and the options there are different icons that display. I have had the update and I do not have the seat icon there.
 

·
F Pace Expert
Joined
·
2,546 Posts
- once in a while, maybe one out of twenty starts, I get black screen at first but then boots fine after 10 seconds or so.
- i recall reading full boot up for ICTP is 90 seconds so I frequently get not available if I try to access nav in less than 90 seconds after start
- my iphone music is fine, podcasts are a mess but always have been, duplicate listings, etc., I don't really use playlists. maybe disassociate phone and then relink?
- no problems entering nav but I find it so annoying anyways so I generally use Route Planner for 90% of my nav stuff, even in vehicle
- i have a physical button for climate so that hasn't changed

While supposedly 2.5 only smooths loading of update I had it done after October update and it fixed a sporadic problem with reverse screen/cameras so I think there some subtle added fixes in there. I wouldn't rush to have it done but if in for service I'd ask that it be done.
 
  • Like
Reactions: uncheel

·
Registered
Joined
·
89 Posts
I had the "super update"performed when I took delivery of my FP mid November and have had virtually no issues. I have a service appointment next week for a few minor things and I mentioned the very loud phone ring for incoming calls. The service manager told me I am due for the 2.5 update and that it may solve this problem. Can anyone confirm if the 2.5 update helps with this issue?
 

·
Registered
Joined
·
99 Posts
I had the "super update"performed when I took delivery of my FP mid November and have had virtually no issues. I have a service appointment next week for a few minor things and I mentioned the very loud phone ring for incoming calls. The service manager told me I am due for the 2.5 update and that it may solve this problem. Can anyone confirm if the 2.5 update helps with this issue?
This update will not address the loud ringer issue. You must be using an Android device. I am told however that this issue has finally been addressed and is scheduled for the next ICTP update.
 
  • Like
Reactions: JMB

·
Registered
Joined
·
223 Posts
We had the 2.0 Super update done in December. It fixed several issues and created some some new ones. We just had a loss of function from the cubby - the SIM no longer worked, music on the USB memory stick was no longer recognized, and the phone cable stopped working. I expect the diagnosis would be a blown fuse of some vague cause. Apparently not. They concluded what we needed was the 2.5 release. The good news is that all of those problems were fixed. The bad news is that our Nav system no longer talks. The dealer is investigating with engineering.
 

·
Registered
Joined
·
90 Posts
This update will not address the loud ringer issue. You must be using an Android device. I am told however that this issue has finally been addressed and is scheduled for the next ICTP update.
Interesting. Did you hear anything on the timing of the next update?

Anyone have any intel?
 

·
Registered
Joined
·
154 Posts
Just got an update today, referred to as "3.0". It solves the ringer issue.
 
  • Like
Reactions: RJurman1

·
Registered
Joined
·
5,074 Posts
Just got an update today, referred to as "3.0". It solves the ringer issue.
I guess this means I don't have to worry about asking for the *2.5* ? How long did it take your service department to install the *K437* (3.0) Update ?
 

·
F Pace Expert
Joined
·
2,546 Posts
Just got an update today, referred to as "3.0". It solves the ringer issue.
There is as of today a more detailed, improved format version of K437NAS3 Service Action: InControl Touch Pro 2.5 document (VIN#'s 046166-049746) but it has no changes in symptoms it refers to. Looks like exactly same instructions but prettier - and maybe less error prone because of it. It was released today.

It appears they are slip streaming patches for specific unresolved item into 2.5 as they are developed and then incrementing a sub version number NAS3.

So people should be specifically asking for K437NAS3 but it is still overall the ICTP 2.5 software update.
 
  • Like
Reactions: GRVR and RJurman1

·
Registered
Joined
·
99 Posts
There is as of today a more detailed, improved format version of K437NAS3 Service Action: InControl Touch Pro 2.5 document (VIN#'s 046166-049746) but it has no changes in symptoms it refers to. Looks like exactly same instructions but prettier - and maybe less error prone because of it. It was released today.

It appears they are slip streaming patches for specific unresolved item into 2.5 as they are developed and then incrementing a sub version number NAS3.

So people should be specifically asking for K437NAS3 but it is still overall the ICTP 2.5 software update.
Thanks guys. I have already sent info to my dealer and he will contact me on Monday. Knowing this issue is resolved is huge for me.
 

·
Registered
Joined
·
154 Posts
I guess this means I don't have to worry about asking for the *2.5* ? How long did it take your service department to install the *K437* (3.0) Update ?
Hi GR, don't know exactly. they had it for 2 full days, but I don't know how long they actually worked on it. I was using the remote app to see if/when it changed location, hood up, window open, etc. And it did show that activity, but it was all the same overnight; so the work was spread over both days, but I dunno!

VZX also indicated this is still considered part of the 2.5 update (although my paperwork does says 3.0, but maybe they are placating me, trying to make it sound like more of an update than it really is?) and I don't care what they call it! As long as the phone doesn't make you deaf with the ringing.

For me, this was the last issue that needed "tuning up". There is so much technology in cars today, I don't care if there is the occasional system "burp", as long as it generally works. And it does...

Now I'm hoping for the eventual addition of Apple Car Play and the Android equivalent, but I kinda doubt that will ever happen.

While in the shop, I got an oil change ($200 big ones, including 25 bucks for the filter--whaaaaatttt? and 11 bucks for a drain fill plug? (maybe from the factory it comes with a non-serviceable plug so it can't leak in transit? The diesel took 7 quarts of oil.

All in all, a very good day.
 
  • Like
Reactions: GRVR

·
F Pace Expert
Joined
·
2,546 Posts

·
Registered
Joined
·
5,074 Posts
Not if you have it done early, which some old school folks, like me, have done.
Did you mean "Old School" , or just "Old" ??? >:)
 

·
F Pace Expert
Joined
·
2,546 Posts
  • Like
Reactions: GRVR

·
Registered
Joined
·
21 Posts
So I had the update done last week. Didn't have many issues to begin with, but was in anyway, so I let them do it.
It now will frequently not have SXM available. Before the update, I could switch to AM/FM, then switch back to SXM and it would work. That doesn't work now, so I have no SXM for the remainder of the trip (and if i make a quick stop, and it hasn't completely powered down. the outage continues). Not great.

On the bright side, Route Planner now works, although it can be slow to pop up in nav.
 

·
Registered
Joined
·
99 Posts
So I had the update done last week. Didn't have many issues to begin with, but was in anyway, so I let them do it.
It now will frequently not have SXM available. Before the update, I could switch to AM/FM, then switch back to SXM and it would work. That doesn't work now, so I have no SXM for the remainder of the trip (and if i make a quick stop, and it hasn't completely powered down. the outage continues). Not great.

On the bright side, Route Planner now works, although it can be slow to pop up in nav.
This is very odd. Since my 2.5 update, almost all of my issues were resolved and there were plenty of them. You may want to have them replace the entire module since on some updates, some reportedly still had issues. Mine was a module replacement.
 
  • Like
Reactions: VZX-CO and GRVR

·
F Pace Expert
Joined
·
2,546 Posts
So I had the update done last week. Didn't have many issues to begin with, but was in anyway, so I let them do it.
It now will frequently not have SXM available. Before the update, I could switch to AM/FM, then switch back to SXM and it would work. That doesn't work now, so I have no SXM for the remainder of the trip (and if i make a quick stop, and it hasn't completely powered down. the outage continues). Not great.

On the bright side, Route Planner now works, although it can be slow to pop up in nav.
Might demand a re-do. I have no problems with SXM since update.
 

·
Registered
Joined
·
1,238 Posts
I'll echo VZX, mine was delivered with the latest ICTP update in mid-January and I've never had any issues with SXM.
 
1 - 20 of 28 Posts
Top