Jaguar F-Pace Forum banner

1 - 20 of 590 Posts

·
Super Moderator
Joined
·
2,171 Posts
Discussion Starter #1
Could we please use this thread to list the problems we find with the software/firmware on the Infotainment/Navigation systems so we can track them. Please enter the problems you find and what you have been able to do to either temporarily or permanently fix the problem.
 

·
Super Moderator
Joined
·
2,171 Posts
Discussion Starter #2
I will start with the following:

Sirius freezes, can't change stations
When set to AM-PM clock vs. 24 hour clock, 24 hour clock shows up for some time before changing to AM-PM
Infotainment screen did not come on when car was started
USB media freezes

I don't have any answers yet but I hope others will chime in with the same or different issues. We need to document these issues not only for ourselves and the FP community we need to make JLR aware of the downfalls of the systems so that they may be corrected. Thanks in advance for everyone input.
 

·
Registered
Joined
·
542 Posts
Right on time. Today I was back parking into a spot, and I realized I took over two spots, lol, so I quickly put it on drive and then reversed again but the camera wouldn't show up so I clicked on the parking sensor button the the Pro screen and it froze. I turned off the car and everything shut down except the frozen screen. I turned on and off the car and stil the same frozen screen. Eventually I have up, had lunch and came back to a working screen. I think it was too much for the processor but that was very odd.
 

·
Registered
Joined
·
290 Posts
Right on time. Today I was back parking into a spot, and I realized I took over two spots, lol, so I quickly put it on drive and then reversed again but the camera wouldn't show up so I clicked on the parking sensor button the the Pro screen and it froze. I turned off the car and everything shut down except the frozen screen. I turned on and off the car and stil the same frozen screen. Eventually I have up, had lunch and came back to a working screen. I think it was too much for the processor but that was very odd.
This has also happened to me .
 

·
Registered
Joined
·
5 Posts
I had an episode where the volume button wouldn't work. I couldn't change the volume at all. Had to restart the car.

Also had the parking problem where the screen freezes when activating cameras.

Finally, the sim card is not working (Jaguar is 'working' on fixing it).
 

·
Registered
Joined
·
542 Posts
Not sure if it's a problem or by design but front sensors never turn on unless you back park or press the Parking Sensor button. I know it's been mentioned before but i figured I add it to this thread.
 

·
Registered
Joined
·
542 Posts
Sirius XM Issue:
When you add a station to a favorite, the Thumbnail is sometimes the station's respective Thumbnail or sometimes it's a weird blue pixelated thumbnail. Problem is that the weird blue thumbnail typically always shows up and it's the same one for all stations so the thumbnail is really useless if it doesn't work right.

Bluetooth Audio issue:
I use Bluetooth for music with Spotify. If I play a song, the song info (artist, song, etc.) pops up on the dash and Pro screen, but if I skip a song (fast forward to next track), the new song info flashes for a second and then disappears, causing blank dots to appear.
 

·
Registered
Joined
·
88 Posts
Not sure if it's a problem or by design but front sensors never turn on unless you back park or press the Parking Sensor button. I know it's been mentioned before but i figured I add it to this thread.
And you still recommend I accept this vehicle in a couple of days?
 

·
Registered
Joined
·
542 Posts
Not sure if it's a problem or by design but front sensors never turn on unless you back park or press the Parking Sensor button. I know it's been mentioned before but i figured I add it to this thread.
And you still recommend I accept this vehicle in a couple of days?
Haha - I've gotten used to pressing the button. Plus the driving with experience is so much fun.
 

·
Registered
Joined
·
40 Posts
Right on time. Today I was back parking into a spot, and I realized I took over two spots, lol, so I quickly put it on drive and then reversed again but the camera wouldn't show up so I clicked on the parking sensor button the the Pro screen and it froze. I turned off the car and everything shut down except the frozen screen. I turned on and off the car and stil the same frozen screen. Eventually I have up, had lunch and came back to a working screen. I think it was too much for the processor but that was very odd.
Have the Problem, too. But my camera is not working anymore (nearly 10 days). The whole System ICTP Needs to start 5min almost. Just black Screen/Jaguar boot logo all during the time.
Dealer doesn't know why.
Have an appointment next week! Hope they can fix it or I really get angry.
 

·
Registered
Joined
·
139 Posts
I have ICT, not ICT Pro, and haven't experienced any of the above issues (except that the parking sensor is not on full-time, but that seems to be intentional on Jaguar's part).

Only complaint with the ICT system is that it takes about 30-45 seconds from starting the car to full boot-up of the system (where I can change radio stations, etc.). Interestingly, it co-incides almost exactly with the time it takes for the engine to fully settle from cold start (when the RPM's drop below 1000). So, basically, I start the car and wait for the engine to settle, and by the time I'm ready to put the car in gear the ICT system is fully up.
 

·
Registered
Joined
·
14 Posts
My system is seriously delayed, even when going from drive to reverse to see the camera ect. I imagine that all jags with this system experience this but I'm surprised they wouldn't address it considering its in all the cars as well.
 

·
Registered
Joined
·
62 Posts
A few thoughts:

Same issue with Sirius/XM. Goes silent a few times a day and comes right back after I switch to radio for a second.

Yesterday after leaving a restaurant, my rear view camera stayed on the whole ride home. Really weird seeing that in your peripheral vision while driving. Screen was otherwise inoperable until I got home, turned off and locked the car. OK after restart. While the system was locked in "rear view camera" mode, none of the controls on the left side of the steering wheel worked either.

On the bright side, driving in to work tonight I noticed a 3G signal indicator and confirmed that the in car internet connection is working. I have not had any contact with AT&T other than a failed chat attempt the other night where he suggested I go to the store for a new SIM. Seems the info finally filtered down from Jag to AT&T after 10 days.

Same issues with front parking camera as others. Seems to randomly work.

Hopeful that as updates come over the air these issues will iron out. The price of early adoption.....
 

·
Registered
Joined
·
159 Posts
ICTP Issues

Could we please use this thread to list the problems we find with the software/firmware on the Infotainment/Navigation systems so we can track them. Please enter the problems you find and what you have been able to do to either temporarily or permanently fix the problem.
How many have experienced no issues?
 

·
Super Moderator
Joined
·
2,171 Posts
Discussion Starter #16
It should not be about early adoption. The electronics in the car should have been nearly perfected by now. That is why I started this thread. I will at some point try to find out what it will take to get someone from Jaguar to "look in" on this forum. They do it in England why not here?
 

·
Registered
Joined
·
542 Posts
Most of the software stuff should be taken care of already and also the easiest to fix since it is just updates. I'm not expecting s flawless system because even our phones aren't flawless but it should be close. I hope Jag has a good software team on top of this.
 

·
Registered
Joined
·
253 Posts
I have ICT, not ICT Pro, and haven't experienced any of the above issues (except that the parking sensor is not on full-time, but that seems to be intentional on Jaguar's part).

Only complaint with the ICT system is that it takes about 30-45 seconds from starting the car to full boot-up of the system (where I can change radio stations, etc.). Interestingly, it co-incides almost exactly with the time it takes for the engine to fully settle from cold start (when the RPM's drop below 1000). So, basically, I start the car and wait for the engine to settle, and by the time I'm ready to put the car in gear the ICT system is fully up.
I've started using my keyfob buttons to unlock the door. Gives me an extra 10 seconds of allowing be ICT system to boot up before I get in car.
 

·
Registered
Joined
·
497 Posts
Yesterday after leaving a restaurant, my rear view camera stayed on the whole ride home. Really weird seeing that in your peripheral vision while driving. Screen was otherwise inoperable until I got home, turned off and locked the car. OK after restart. While the system was locked in "rear view camera" mode, none of the controls on the left side of the steering wheel worked either.
Any chance you hit the rear camera button right below the Park Assist button :confused:? I thought that it was odd that one can do that, look rearwards as you drive forward but you certainly can do it by pressing the button. I remember my Salesguy saying "what a weird feature that is". My BMW i3 does that sometimes after backing up. It won't get out of reverse sensor screen for about a minute.

While my ICT system seems to work perfect, I find it really odd that these cars (w/ ICTP) could go out the door with so may inherent software problems. Sucks for you ICTP people. Anyone on the fence about buying an FPace I'd sure recommend the smaller screen and etc... It's still way big, and no problems and voice commands for all you fans of that.
 
1 - 20 of 590 Posts
About this Discussion
589 Replies
152 Participants
thejerseydevil
Jaguar F-Pace Forum
Jaguar F-Pace Forum is the best community to discuss the SUV’s towing, interior, reliability, mods, AWD, SVR models and more.
Full Forum Listing
Top