Jaguar F-Pace Forum banner

Did you get the update?

  • Yes, It just popped up and I installed it.

    Votes: 19 54.3%
  • Yes, I got it, but did something to request it.

    Votes: 6 17.1%
  • No.

    Votes: 3 8.6%
  • What update?

    Votes: 7 20.0%
21 - 40 of 42 Posts

·
Registered
Joined
·
1,153 Posts

·
Registered
Joined
·
150 Posts
you can now use cameras up to 35 kmh btw
Was this posted in a change log somewhere? (with the other updates and fixes for this release) Or did you discover this one your own? What was the previous speed that disabled the camera view?
 

·
Registered
Joined
·
1,246 Posts
It's been two weeks with the update and so far I'm still logged into InControl so that issue finally appears to be fixed.
 

·
Registered
Joined
·
1,153 Posts

·
Registered
2018 R Sport 2,5D satin black 22´´double spoke wheels,full except configurable ambient lighting
Joined
·
19 Posts
I discovered it on my own. Before the cameras went away immediately after car started to move forward, now they stay on until 35 km/h
 

·
Registered
2016 F-Pace 3.0 S
Joined
·
4 Posts
I've just become the proud owner of a 2016 F-Pace 3.0 S. I have no software update option in the ICTP screen & am on version 20.14-1165 (with no activation date), which I believe is the original version in the car. I've asked my local dealer about a software update, so they've booked me in to 'activate Apple car play' (their words, not mine, which is worrying me already). They can't fit me in for a month (which is a real pain), so I rang another dealer - they told me "according to Jaguar, there is nothing outstanding for your vehicle" - I've been trying to find the software to download & do it myself (no luck yet), but with everything I'm reading about how temperamental it can be, i'm not even sure I want to try that (and I'm pretty good with technology). Anyone got any recommendations for really good dealers, who actually know their products, around Derby, Uk?
Output device Gadget Font Display device Electronic device
 

·
Registered
Joined
·
1,246 Posts
The dealer will have to update the system to enable CarPlay and Android Auto. These features came with a later version of ICTP software as well as the ability to support SOTA updates. There's no way to do this on your own from this version.
 

·
Registered
2016 F-Pace 3.0 S
Joined
·
4 Posts
Thanks Gorgon, that’s a shame, as they haven’t filled me with confidence so far - I’ll post back to let others know how I get on once it’s been done 👍
 

·
Registered
Joined
·
261 Posts
Per my dealer, the fix to get audio with CarPlay is coming in August. Allegedly it will be available OTA (assuming your system is current/set to get OTA).
 

·
Registered
Joined
·
68 Posts
How do you "set" your system to get OTA updates? Is there an actual setting you need to choose? I still don't have any information on the "latest update" screen where I've seen others show the latest version, etc. mine shows nothing...even though I've been to the dealer and had the incontrol issue fixed. Maybe I just haven't had an update yet?
 

·
Registered
2016 F-Pace 3.0 S
Joined
·
4 Posts
Well, my dealer finally managed to update my ICTP - took him 4 attempts & apparently ended up having to completely reset the module that actually drives the ICTP (can't remember what he called it). Now on version 21A, and also have the 'no audio' issue with sat-nav (Waze) through CarPlay. My wife has found that pressing the 'Mode' button on the steering wheel a couple of times sorts this, although it resets every time you turn the car off, so you need to do it each time, but that's no big deal while we wait for a fix.
 

·
Registered
2016 F-Pace 3.0 S
Joined
·
4 Posts
Anybody knows any solution for lack of noise in navigation with any app of CarPlay and last version S21A_21.10.6-676616???
Try pressing the 'Mode' button on the steering wheel a couple of times after activating your CarPlay nav app - seems to do the trick! (although it resets each time you turn off, so you have to repeat it each time you want the voice)
 

·
Registered
Joined
·
1,430 Posts
How do you "set" your system to get OTA updates? Is there an actual setting you need to choose? I still don't have any information on the "latest update" screen where I've seen others show the latest version, etc. mine shows nothing...even though I've been to the dealer and had the incontrol issue fixed. Maybe I just haven't had an update yet?
There may be another set of rules for Pivi Pro if that's what you have. Our P400 should arrive next week, and we are hoping they have it updated and figured out...
 

·
Registered
Joined
·
249 Posts
I haven't been driving my car as much as usual. Bought new in 2017 and still only has 39k miles on it. I last had it serviced in February and I asked for the latest update since I haven't been getting any OTA notifications, like I should. They said it had the latest version already on it. But then I noticed what looks like a download icon on the top right. Whenever I check for an update it says I have the latest. Now, I know there was an update in April but my system still says there isn't. This photo was taken a few minutes ago. Anyway to jump start it without making a trip to the dealer?

73830
 

·
Registered
Joined
·
1,246 Posts
I haven't been driving my car as much as usual. Bought new in 2017 and still only has 39k miles on it. I last had it serviced in February and I asked for the latest update since I haven't been getting any OTA notifications, like I should. They said it had the latest version already on it. But then I noticed what looks like a download icon on the top right. Whenever I check for an update it says I have the latest. Now, I know there was an update in April but my system still says there isn't. This photo was taken a few minutes ago. Anyway to jump start it without making a trip to the dealer?
Since the latest update breaks CarPlay audio you might want to hold off on forcing the update. JLR has acknowledged this issue and the current option to address the lack of audio is the bring it to the dealer to downgrade to the previous release. It might be some remnant of JLR holding. back the latest release until they fix whatever was broken.
 

·
Registered
Joined
·
261 Posts
MeBuff8Fan - Your ICTP software is a couple of years behind. If you're not having any special issues, it's probably not worth a special trip to the dealer. When you do go, make sure they enable CarPlay while they're at it. Meanwhile, JLR will hopefully release a fix to the main current problem on CarPlay audio (discussed above).
 

·
Registered
Joined
·
6 Posts
I haven't been driving my car as much as usual. Bought new in 2017 and still only has 39k miles on it. I last had it serviced in February and I asked for the latest update since I haven't been getting any OTA notifications, like I should. They said it had the latest version already on it. But then I noticed what looks like a download icon on the top right. Whenever I check for an update it says I have the latest. Now, I know there was an update in April but my system still says there isn't. This photo was taken a few minutes ago. Anyway to jump start it without making a trip to the dealer?

View attachment 73830
I just purchased a 2019 with version 19A with no car play. When I checked for updates, I got the same message. Later I learned the SIM card was not recognized so no mobile connection. I connected to my home Wifi, searched again and downloaded an update that enabled car play. It is at 20A now and at the dealer getting the mobile network sorted out.
 
21 - 40 of 42 Posts
Top