Jaguar F-Pace Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
After a very long process to get my F-Pace S ordered from Jaguar of Minneapolis with exactly what I wanted... my sales rep was fired and nobody followed through, so when I called back a couple weeks later to check on things, I ended up starting over and lost my slot. Frustrating, since it put me out three months, but a new sales guy was able to grab an incoming from another dealer that was configured closeish, and I took delivery about the time I expected; just with a few different things I was looking for, but acceptable.

I picked it up five days ago and have about 300 miles on it, and I already have a list... Some are valid issues, and some are gripes. I feel like the coders of the system don't actually use the features they wanted installed, or they've never seen smooth integration of said components.

-I have the smell in the cabin and hop on turns from a stop, so I read on here it's likely the diff leak and I need to check for leaks and make dealer appointment.
-I have a rattle in the door panel during moderate speaker volume, so I'll have to have the dealer look into that.
-My remote start works about 20% of the time. I've deleted the app and all that, tested on various connections, etc. I am very sure that it's not my mobile device connectivity since I've tried many locations on many fast Internet connections and can use many other data-hungry apps with ease. This is frustrating since everyone wants a ride since it's new, and I can't even warm up the car without walking out like some sort of savage. ;) It IS below zero out here now.
-My center display (I have tech package) sometimes takes longer to turn on when I start the vehicle. It stays black for maybe two-three minutes, then begins the boot process. Most of the time I start it, however, it powers right up (even overnight). I haven't seen any posts about this during my browsing.
-My bluetooth sometimes disappears and has been unable to connect until I restart the vehicle, but then works fine after that. Embarrassing, but hasn't been a huge issue. This never happened in my previous vehicle, and my watch stays connected. (I love my BT streaming audio.)
-Insane how the In Vehicle Apps thing on the iPhone is archaic... I'm hoping for more Apple CarPlay support like they advertised.
-My mobile phone GPS isn't accurate only when in the car; I believe I read this is due to a window coating. Is that the case? What is that coating for?
-My windshield is heated (with little lines) and has the coating mentioned above for something... but it makes my expensive polarized glasses seem like things are blurry/shaking. Anyone else experience this? It borders on motion sickness if I am focusing on letters or something in the distance.
-Mine came with the 'protection package' which are rubber floor mats. I want to express my deepest sympathies for anyone else who ended up with this waste of money, but luckily, my WeatherTechs arrived today. (They just allow all the runoff directly onto the carpet of the vehicle and they're way too small for the footwell area.)
-My wife's Dodge knows to turn on the steering wheel and driver's seat during remote start (and when starting traditionally) depending on outside temperature. It was less than half the price of the Jag and is three years old... My F-Pace S sometimes seems to remember previous seat setting (I think when remote start is used), but usually doesn't. Also, my 'favorite seat' shortcut button doesn't remember my setting of 'driver on high' all the time, and sometimes turns on passenger only, or sometimes does nothing. I think it's a 'previous setting' button instead of a setting like the display guides you to think.
-I get TONS of debris road noise from under the car. It's excessive when the tires pull up little rocks/sand/salt from winter roads. The wind noise and overall quietness is great, but the debris noise is super noticeable. Anyone else notice this?

Qs!
-Is there a way to start from the fob like a traditional remote start?
-Where can I find the trip info that isn't in Eco Data? I want to be able to view Distance to Empty from time to time, and I feel like it should be near the left side of the driver LCD where the audio panel goes, but I can't figure out how to cycle through to it. I only have clock, the Jag logo, and the audio panel.

Other than the list above, it's a fine automobile. It looks beautiful on the outside and has great interior. Seats are superbly comfortable, driving position fits me well, and when the tech works: it's fun to have all the features. I do intend on loving the vehicle once some of the quirks are solved. I adore the display swap of tach and speedo positions when I put it in Dynamic mode, and the red highlights when in S is pretty awesome. The Meridian sound system (in Dolby mode) has an awesome [high] sound stage with great energy, although like most middle-lux it lacks low bass extension and has unnecessarily peaky booms. The overall performance seems stable and consistent, although to be fair, I'm very used to turbo vehicles without so much shifting. The SC + 8 gears will take some getting used to, but I think I'll enjoy it once I've put some miles on it.

I read on a different thread that there is a different load floor if you don't have a spare tire. I didn't find the details on this or photos/descriptions, but I'd be interested in getting a bit more luggage compartment space on certain trips by sacrificing the security of a spare.

Sorry for the rant; I'm not trying to be ridiculously picky, but it is an expensive vehicle from a name I expected a bit more from. If anyone wants to chime in, I'd be interested in comments.

Thanks!
-Rocky
 

·
Registered
Joined
·
5,082 Posts
Hello ! *GR* here !
Not the Best Reputation , but every once in a Blue Moon , I try to put forth a helpful tid-bit !!! ;)

1. The push button on the end of the Turn Signal Stock , will take away the Eco Mode Bars in the center of the Driver LCD , and then display "Distance to Empty" ! Which is what I prefer to see !

2. If you have a 3"-4" HUMP in the Cargo Floor , it means you must have a "FULL SIZE SPARE" ! The regular Flat Floor in the Cargo Area , still has a Space Saver Spare Tire , just not a Full Size one !

That's ALL I got for you right now !!! Welcome to the Forum !!!
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Hello ! *GR* here !
Not the Best Reputation , but every once in a Blue Moon , I try to put forth a helpful tid-bit !!! ;)

1. The push button on the end of the Turn Signal Stock , will take away the Eco Mode Bars in the center of the Driver LCD , and then display "Distance to Empty" ! Which is what I prefer to see !

2. If you have a 3"-4" HUMP in the Cargo Floor , it means you must have a "FULL SIZE SPARE" ! The regular Flat Floor in the Cargo Area , still has a Space Saver Spare Tire , just not a Full Size one !

That's ALL I got for you right now !!! Welcome to the Forum !!!
Awesome, thanks! The turn-signal button worked great!

I don't have a hump; it's all flat. This must mean I have the space saver spare, and it's as good as it gets for cargo.

Thanks for the reply!
 
1 - 3 of 3 Posts
Top