Jaguar F-Pace Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I’ve been using CarPlay for a while with my 2017 F-Pace...it has now hijacked my system and will not function. Touchscreen will not work while CarPlay screen is displayed. I cleared the vehicle from my phone thinking I could pair it with the car again...nope. Message states “Bluetooth unavailable while CarPlay is running”...except it isn’t running. Now I can’t even use my phone hands free with the system, and F-Pace is not showing up to pair with my phone’s Bluetooth ... suggestions?
 

·
F Pace Expert
Joined
·
2,546 Posts
Just tossing things out:
1) Have you cleared the phone from the vehicle? Any other phones or bluetooth devices paired with car?
2) Yea old have tried a different cable yet?
3) Are you doing your testing with a complete cold boot of car, eg it's been sitting off an locked for more than 30 minutes?
4) Are you on most updated ICTP?
5) Are you on most updated IOS?
6) Have you cold rebooted phone, ie shut down and restarted phone?
7) There was a weird glitch for some honda owners with IOS 14 and solution was "So what you need to do is change the background to solid black – this could actually be an indication that the bug is caused by the new wallpaper support feature that’s bundled with iOS 14. To do this, open the settings screen on CarPlay right on the head unit and pick the solid black option. Then, turning off Siri suggestions and album art seems to help too, as for some reason, CarPlay then runs properly with a reduced likelihood of crashes" - unlikely to help but throwing it out there.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Just tossing things out:
1) Have you cleared the phone from the vehicle? Any other phones or bluetooth devices paired with car?
2) Yea old have tried a different cable yet?
3) Are you doing your testing with a complete cold boot of car, eg it's been sitting off an locked for more than 30 minutes?
4) Are you on most updated ICTP?
5) Are you on most updated IOS?
6) Have you cold rebooted phone, ie shut down and restarted phone?
7) There was a weird glitch for some honda owners with IOS 14 and solution was "So what you need to do is change the background to solid black – this could actually be an indication that the bug is caused by the new wallpaper support feature that’s bundled with iOS 14. To do this, open the settings screen on CarPlay right on the head unit and pick the solid black option. Then, turning off Siri suggestions and album art seems to help too, as for some reason, CarPlay then runs properly with a reduced likelihood of crashes" - unlikely to help but throwing it out there.
I’ve tried most of those things...but I can try the others, thank you!
I unpaired my phone’s CarPlay from my car, and now I can’t pair my phone at all, either thru Bluetooth or CarPlay. Without my phone plugged in or paired, the CarPlay screen still comes up on my car, but I can do nothing with it. The touchscreen stops working when the CarPlay launches.
 

·
Registered
Joined
·
2 Posts
I’ve tried most of those things...but I can try the others, thank you!
I unpaired my phone’s CarPlay from my car, and now I can’t pair my phone at all, either thru Bluetooth or CarPlay. Without my phone plugged in or paired, the CarPlay screen still comes up on my car, but I can do nothing with it. The touchscreen stops working when the CarPlay launches.
I had an experience very similar to yours in my 2018 XF. In my case it started happening immediately after I upgraded my phone to iOS 14; I had the lock-up scenario the OP describes, which could only be corrected by turning off and locking the car and leaving it sit long enough for all dashboard systems to time out. I also had another scenario beyond what the OP has described: at times CarPlay would work properly with the phone but all location services on the phone we’re delayed by somewhere between five and 10 minutes, which made it impossible to do navigation or even to order fast food on several of the fast food apps which use location services.

I could not find a way to fix this other than unplugging, turning off the car and letting it time out; no other sequence of steps worked, including resetting the dashboard setting, rebooting the phone and various combinations of small and large changes

Ultimately I decided to try other iPhones in my car and discovered that they worked even though they were running iOS 14. I also tried my phone and other cars with CarPlay and it worked properly. The problem was unique to my phone and my XF.

As a last resort (after making a full back up) I reset my phone completely to factory default settings. After that reset it did work properly with CarPlay. I then restored my back up and the problem returned.

At this point I contacted Apple support and went through three layers of support and ultimately had an online session with third level support person at Apple to demonstrate my issue. Apple told me they would investigate on their side with the software engineers, using an image of my phone’s software and a transcript of its communications with the dash, and get back to me in a few days.

When they did get back, unfortunately they said the only answer they could provide me was that I should reset my phone to factory settings, sign back in on my Apple ID, and then reinstall the apps and home screen arrangement and wallpapers. Reluctantly, I concluded this is what I would have to do. So I took some images of my app and screen arrangements, and reset the phone and proceeded to slowly rebuild it. The good news is now everything works correctly. I reinstall apps only one or two at a time with a few days between so that I can make sure that it is not a specific app that is creating the problem. So far I have not been able to tie the problem to any particular app and the phone continues to work even as I have installed nearly all of the offs I had previously.

I wish I had a better answer for you but I hope at least this drastic approach (which you can test by taking a backup and resetting your phone) is a way out for you.
 
1 - 4 of 4 Posts
Top